Difference between revisions of "Installation guide"

From mcMMO wiki
Jump to: navigation, search
(Upgrading from Classic)
 
(11 intermediate revisions by 2 users not shown)
Line 1: Line 1:
==Installation==
+
== Choosing the appropriate mcMMO version ==
  
===Upgrading from Classic===
+
There are many versions of Minecraft, Spigot, Paper, and mcMMO. To choose the best version, refer to [[Version compatibility|Version compatibility]].
  
If you are upgrading from classic or a previous mcMMO install
+
==Fresh Install==
 
 
'''1.''' It is recommended you delete advanced.yml, experience.yml, and salvage.vanilla.yml in order to generate updated config files
 
 
 
'''2.''' Put mcMMO.jar into the /plugins/ folder inside your server directory.
 
 
 
'''3.''' Congratulations mcMMO is now installed.
 
 
 
===Fresh Install===
 
  
 
If you have never installed mcMMO before
 
If you have never installed mcMMO before
Line 19: Line 11:
 
'''2.''' Configure your server and run it once with Spigot/PaperMC to generate a plugins folder. You can also make the plugins directory manually. Close the server after it has created the plugins directory.
 
'''2.''' Configure your server and run it once with Spigot/PaperMC to generate a plugins folder. You can also make the plugins directory manually. Close the server after it has created the plugins directory.
  
'''3.''' Download the [[Public mcMMO Releases| latest public release of mcMMO]] from the Spigot page.
+
'''3.''' Download the [[Public mcMMO Releases|latest public release of mcMMO]].
  
 
'''4.''' Drag and drop '''mcMMO.jar''' into the plugins directory.
 
'''4.''' Drag and drop '''mcMMO.jar''' into the plugins directory.
Line 25: Line 17:
 
'''All done!'''
 
'''All done!'''
  
The next time you run your Spigot/PaperMC server, mcMMO will enable itself and generate many configuration files for you to modify in ''server_directory_here\plugins\mcMMO''.
+
The next time you run your Spigot/PaperMC server, mcMMO will enable itself and generate many [[Config|configuration files]] for you to modify in ''server_directory_here\plugins\mcMMO''.
  
===Additional Steps===
+
==Upgrading from Classic==
  
Start up the server once, and then close it and then edit the config files to your liking
+
If you are upgrading from classic or a previous mcMMO install
 +
 
 +
'''Note:''' mcMMO and mcMMO Classic share the same DB, you will never EVER lose data from upgrading! Upgrading will always be completely safe!
 +
 
 +
 
 +
'''1.''' It is recommended but not required to delete [[advanced.yml]], [[experience.yml]], [[treasures.yml]], and [[salvage.vanilla.yml]] in order to generate updated [[Config|config files]].
 +
 
 +
'''2.''' Put mcMMO.jar into the /plugins/ folder inside your server directory.
 +
 
 +
'''3.''' Congratulations mcMMO is now installed.
 +
 
 +
==Additional Steps==
 +
 
 +
If you'd like to customize mcMMO after installing it, here are some tips.
 +
 
 +
Start up the server once to generate [[Config|config files]], if they don't exist, then close it and edit the [[Config|config files]] to your liking.
  
 
If you want the skill system to be from 1-1000 turn on RetroMode in config.yml
 
If you want the skill system to be from 1-1000 turn on RetroMode in config.yml
  
RetroMode will turn itself on if mcMMO finds config.yml in your /plugins/mcMMO/ folder from a previous install!
+
mcMMO automatically turns RetroMode on if it finds config.yml in the /plugins/mcMMO/ folder from a previous install!
 
 
If you'd like the skill system to be from 1-100 turn off RetroMode in config.yml
 
  
=== Choosing the appropriate mcMMO version ===
+
If you prefer the skill system to be from 1-100: turn off RetroMode in config.yml
  
There are many versions of Minecraft, Spigot, Paper and mcMMO. To choose the best version, refer to [[Version compatibility|Version compatibility]].
+
For all further configuration see: [[Config]]
  
  

Latest revision as of 06:02, 14 April 2019

Choosing the appropriate mcMMO version[edit]

There are many versions of Minecraft, Spigot, Paper, and mcMMO. To choose the best version, refer to Version compatibility.

Fresh Install[edit]

If you have never installed mcMMO before

1. Make sure you are running the latest stable version of Spigot or Paper.

2. Configure your server and run it once with Spigot/PaperMC to generate a plugins folder. You can also make the plugins directory manually. Close the server after it has created the plugins directory.

3. Download the latest public release of mcMMO.

4. Drag and drop mcMMO.jar into the plugins directory.

All done!

The next time you run your Spigot/PaperMC server, mcMMO will enable itself and generate many configuration files for you to modify in server_directory_here\plugins\mcMMO.

Upgrading from Classic[edit]

If you are upgrading from classic or a previous mcMMO install

Note: mcMMO and mcMMO Classic share the same DB, you will never EVER lose data from upgrading! Upgrading will always be completely safe!


1. It is recommended but not required to delete advanced.yml, experience.yml, treasures.yml, and salvage.vanilla.yml in order to generate updated config files.

2. Put mcMMO.jar into the /plugins/ folder inside your server directory.

3. Congratulations mcMMO is now installed.

Additional Steps[edit]

If you'd like to customize mcMMO after installing it, here are some tips.

Start up the server once to generate config files, if they don't exist, then close it and edit the config files to your liking.

If you want the skill system to be from 1-1000 turn on RetroMode in config.yml

mcMMO automatically turns RetroMode on if it finds config.yml in the /plugins/mcMMO/ folder from a previous install!

If you prefer the skill system to be from 1-100: turn off RetroMode in config.yml

For all further configuration see: Config



Main Page